解决Git更新代码报"The current branch is not configured for pull"错误

一、现象描述

在Eclipse中使用Git更新代码时,弹窗报了”The current branch is not configured for pull”错误。如下图:

解决Git更新代码报

解决Git更新代码报

二、解决办法

①在本地工程目录找到config文件

一般会在你的仓库目录里面可以找到,也可以直接在IDE里面打开,

window ->preference ->team ->git ->configuration ->Repository Settings,Repository选择当前的仓库,然后点右边的open

②修改config文件内容

解决Git更新代码报

③再执行pull方法

如果发现还有弹窗信息,弹窗信息如下:

解决Git更新代码报

这个信息说明代码有冲突,要先解决了冲突才能正常pull代码,具体的可以参考这篇文章解决冲突问题。

至此,我们关于解决Git更新代码报”The current branch is not configured for pull”错误介绍完毕。如果您想了解更多关于Git方面的知识可以参考《Git教程开发》,《Eclipse教程》《IntelliJ IDEA教程》关于如何使用Git工具的系列文章。

博客地址:http://www.marsitman.com/exception/exception-git-pull-not-configure.html
版权声明:本文为博主原创文章,允许转载,但转载必须标明出处。

 

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!



点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注